Bem-vindo à Comunidade UBNT

CloudKey nao abre o portal para autenticação do voucher

ola,
estou utilizando um "cloudkey" em um cliente, mais o portal para o voucher não esta abrindo...

os dispositivos dos usuários se conecta na rede porem o portal não aparece de modo automático
forçando no navegado do dispositivo com https://end-ip-contrroler:8843/ ou http://end-ip-contrroler:8880/ a porta ate abre mais mostra um erro do apache
tentei configurar o mais básico possível somente pedindo o voucher com o legacy, sem resultado
notei que os links de gerencia do portal da versão 4 para 5 mudaram um pouco.
alguma ideia...
Rotulado:

Comentários

  • R4V3RR4V3R 8430 Pontos
    Em computadores completos, diga-se desktops e notebooks, não há pop-up automático informando sobre a necessidade de autenticação da rede, isso apenas será apresentado quando o usuário abrir um navegador web, momento em que ocorre o redirecionamento.
    O endereço de autenticação que você está testando, também não está completo. Tente este: 
    http://end-ip-da-controladora:8880/guest/s/(id do site)/
    Se for o site padrão(default), o id é default mesmo. Por exemplo: http://192.168.1.20:8880/guest/s/default/
    Obs: a barra "/" no final é obrigatória, caso contrário as imagens não carregam corretamente.
  • hassishassis 14 Pontos
    no meu notebook também não esta indo da forma como você descreve, abrindo o navegador e tentando acessar uma pagina qualquer.
    mais forçando no navegado e abrindo a pagina http://end-ip-controler:8880/ ate vai.
    e nos smartphone a mesma coisa.

  • R4V3RR4V3R 8430 Pontos
    Então você consegue acessar normalmente a página de autenticação se digitar conforme informei o endereço acima, é isso?
    Ao se conectar à rede e abrir um navegador, a mesma página não é exibida, porém o acesso à internet está liberado, ou não?
    Se você abrir um prompt do ms-dos e fizer testes de ping para servidores externos, a conectividade é estabelecida ou não?
  • hassishassis 14 Pontos
    a pagina abre sim, ai preenche com um voucher e a internet esta liberada
    e não responde ao ping se você não colocar o voucher.
  • R4V3RR4V3R 8430 Pontos
    Bom, agora estou confuso, pois este é exatamente o comportamento padrão e esperado que ocorra. Não consigo entender o que você está achando errado.
  • hassishassis 14 Pontos
    para um dispositivo móvel, o coerente e que a tela aparece espontaneamente e não que eu deva digitar o endereço do controler e dai preencher com o voucher.
    estamos falando de publico variado que quer praticidade, e não dificuldade
    tenho em outros clientes o mesmo portal funcionando mais com a versão 4.8.15 em uma maquina sem problemas
    mais com este CloudKey com firmware v0.5.2 não esta funcionando da mesma forma
  • R4V3RR4V3R 8430 Pontos
    Certo, mas isso é uma implementação que é feita nos dispositivos, não nos pontos de acesso ou na controladora.
    São apenas alguns dispositivos que exibem este comportamento, ou nenhum dispositivo móvel infoma que o usuário está conectado numa rede de hotspot, e que precisa se autenticar e tal?
  • hassishassis 14 Pontos
    Descobri algo novo nesta historia...
    A estrutura que estou montando fica em um prédio onde os APs estão em andares diferentes onde estão os switches e roteadores. Então  para facilitar os meus testes eu instalei um AP-LR junto a estes para eu não precisar ficar subindo e descendo escada.
    Surpresa minha os teste com este equipamento funcionam corretamente, fazendo a conexão a rede e a tela de solicitação do voucher aparece automaticamente no dispositivo, sem eu precisar mexer em nada.
    porem os equipamentos que eu coloquei neste projeto foram os novos APs AC-Lite, e nestes o portal não aparece de modo automático. fiz mais um teste com um outro AP desta vez um AP PRO, e o mesmo passou no teste também.

    No projeto original são 06 APs AC Lite e um CloudKey.
  • R4V3RR4V3R 8430 Pontos
    Tá mas, você não respondeu em quais estes dispositivos isso ocorre. São apenas alguns, ou todos os dispositivos conectados no UAP-AC-Lite? Se forem apenas alguns, que marcas e modelos mais ou menos?
    Eu estou nesse momento usando um UAP-AC-Lite, é o ponto de acesso que tenho aqui em casa, e está funcionando perfeitamente a rede guest nos dois dispositivos que tenho aqui, um LG Nexus 4 e LG G3. Vou fazer um teste com um iPad à noite pra ver como fica..
  • hassishassis 14 Pontos
    eu fiz teste com um notebook asus, um iPad-Mini, e um celular Samsung e todos tiveram o mesmo comportamento, falham na conexão com o AP-AC-Lite, e funcionam bem no AP-LR e no AP-PRO

    teste feito com AP-LR mais celular Samsung
    https://dl.dropboxusercontent.com/u/39218102/2016-09-16 15.13.33.mov

    teste feito com AP-AC-Lite mais Cel Samsung
    https://dl.dropboxusercontent.com/u/39218102/2016-09-16 15.20.28.mov
  • R4V3RR4V3R 8430 Pontos
    Certo, eu testei com AC-Lite e AC-LR e não consegui identificar este comportamento.
    Me parece ser algo relacionado à resolução DNS, eu estava dando uma olhada nas regras de iptables/ebtables que controlam isso, e consultas de DNS na porta normal, UDP 53 deveriam ser liberadas, para qualquer endereço, mesmo externo, pois é comum as pessoas configurarem o servidor DHCP para entregar servidores DNS do google, por exemplo.
    Então algumas perguntas:
    1) Essa rede guest é completamente isolada das demais(VLAN)?
    2) O servidor DNS utilizado é local?
    3) O que está configurado na controladora em settings/guest control/redirect using hostname?
    4) Qual a versão de firmware que está em uso nestes pontos de acesso que você testou?

    Você pode tentar fazer um teste com um notebook e ver se a resolução de nomes funciona, antes do dispositivo se autenticar nesta rede guest? Eu testei com notebook no windows, funciona tudo normalmente, inclusive ele chama o navegador padrão assim que se conecta na rede guest. No linux isso não ocorre, mas basta abrir o navegador e tentar entrar em um site que não seja HTTPS que ele irá redirecionar para o guest portal.

  • hassishassis 14 Pontos
    desculpe não concordar muito, pois o teste mostrado é a mesma rede...
    e funciona no AP-LR e no AP-PRO e nao funciona com AP-AC-Lite.
    o gateway que atende a vlan guest e a vlan da rede interna é o mesmo, somente alterando os endereços IP distintos de cada VLAN  e com permissão da rede guest para a rede interna para acesso somente ao endereço do controler em todas as portas.
    o gateway é tambem o dns primario para ambas as redes
     
  • R4V3RR4V3R 8430 Pontos
    Certo e a resolução de nomes funciona na rede guest antes de o dispositivo se autenticar?
    E quanto às demais perguntas que menciono acima?
    Eu estou tentando ajudar realmente, mas não estou conseguindo reproduzir o problema que você menciona.
    Uma sugestão que posso fazer é retirar este equipamento(UAP-AC-Lite) de seu local, levá-lo para laboratório, resetar e reconfigurar com uma nova controladora UniFi, e reconduzir os testes com o mesmo, em um ambiente isolado e controlado para ver se o problema persiste.
Entre ou Registre-se para fazer um comentário.