Bem-vindo à Comunidade UBNT

Hotspot Mikrotik com Uni-Fi AP-LR e Guest Policies

Boa tarde. Sou novato no fórum e meu conhecimento é bem pouco na área de redes pois não lido diariamente com a parte de protocolos, camadas, e tudo mais a fundo, necessário acredito para configurar corretamente um mikrotik e um AP Uni-Fi fora das configurações nativas, que são bem intuitivas alias, obrigado Ubiquiti. 

Já venho acompanhando alguns tópicos relacionados a configuração, já instalei e configurei APs da Ubiquiti em vários clientes mas a verdade é que normalmente a topologia vem toda configurada e eu só montava por assim dizer. Tinham duas subredes, que eram controladas por um gateway Astaro que distribuía duas Vlans, tinha um switch gerenciável da Dell e ainda um Mikrotik, que vou ser sincero, não sei muito bem qual era a utilidade já que o Gateway já era Load Balance, provavelmente tinha algo a ver com monitoramento, talvez as Vlans. Enfim, esse switch Dell tinha certas portas "trunkadas" então era só conectar tudo no lugar correto que a rede funcionava corretamente, a LAN possuía duas VLAS pra o ADM e para os Clientes, de praxe. Bom dei esse exemplo pra entenderem meu nível de conhecimento e me orientarem dentro do possível.

Hoje eu tenho uma necessidade bem mais simples eu acho, meu cliente possui 4 APs Uni-Fi LR com 3 Wlas, uma para a Diretoria, outra pra funcionários e uma com guest policies ativada pra Clientes/visitantes, tenho um Mikrotik RB 750 hEX lite com um hotspot configurado nela.
Meu cliente quer um Hotspot personalizado rodando dentro desse MK, configurei um padrão pra testes, criei perfis e usuários normalmente usando tutoriais, meu MK tem acesso a internet normalmente, ao conectar  um notebook a minha ether2 que renomeei para CLIENTES, o computar acessa a rede e é redirecionado para a tela de login, após o login eu navego normalmente. O problema é quando plugo o cabo LAN de um AP Uni-Fi nessa porta, ou em um switch (Não tenho certeza se isso funcionaria também), ao conectar pelo sinal Wifi do AP, sou redirecionado para a pagina inicial do Hotspot mas a mesma não abre, aparece na barra de endereços no navegador mas não navega, nem inserindo o endereço do HotSpot manualmente. Mas o equipamento recebe a faixa de IP do pool que configurei no MK. Alguém pode me orientar? Desculpe pelo tamanho do texto.

Segue configuração da WLAN habilitada no AP que estou usando em laboratório:

image


Segue configuração no Mikrotik:


/interface ethernet
set [ find default-name=ether2 ] name=Clientes
set [ find default-name=ether1 ] name=Link
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
add dns-name=microemicro.rede hotspot-address=10.5.50.1 html-directory=\
    flash/hotspot name=hsprof1
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=aes-128-cbc
/ip pool
add name=hs-pool-2 ranges=10.5.50.2-10.5.50.254
/ip dhcp-server
add address-pool=hs-pool-2 disabled=no interface=Clientes lease-time=1h name=\
    dhcp1
/ip hotspot
add address-pool=hs-pool-2 disabled=no interface=Clientes name=hotspot1 \
    profile=hsprof1
/ip hotspot user profile
add address-pool=hs-pool-2 name="1 Mega" rate-limit=200k/1M session-timeout=10m \
    transparent-proxy=yes
/system logging action
set 1 disk-file-name=log
/ip address
add address=10.5.50.1/24 comment="hotspot network" interface=Clientes network=\
    10.5.50.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
    interface=Link
/ip dhcp-server network
add address=10.5.50.0/24 comment="hotspot network" gateway=10.5.50.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment="place hotspot rules here"
    disabled=yes
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment="place hotspot rules here"
    disabled=yes
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    src-address=10.5.50.0/24
add action=redirect chain=hotspot comment=\
    "Redirecionamento  https  antes  do  login  hotspot" dst-port=443 hotspot=\
    local-dst protocol=tcp to-ports=80
/ip hotspot user
add disabled=yes name=admin
add name=usuario password=123 profile="1 Mega" server=hotspot1
/ip service
set www-ssl disabled=no
/system clock
set time-zone-name=America/Sao_Paulo
/system routerboard settings
set cpu-frequency=850MHz protected-routerboot=disabled
/tool romon port
add
[admin@MikroTik] >


Novamente, desculpe o tamanho da postagem. Espero que possam me ajudar.
Grato pela atenção!


Comentários

  • R4V3RR4V3R 8455 Pontos
    Tente desativar a opção "guest policy" na configuração deste SSID e teste novamente.
    Quanto à configuração no mikrotik, não tenho como ajudar.
    MarlonRocha
  •  @R4V3R chega a ser irônico, mas aparentemente funcionou. Vou tentar continuar implementando isso aqui. Apesar que não consegui navegar corretamente no Firefox, só no Chrome. Pode ser por quê tem um perfil limitando o trafego tanto na WLAN do Uni-Fi quanto no Usuário no HotSpot. Vou fazer mais testes aqui.
Entre ou Registre-se para fazer um comentário.