Bem-vindo à Comunidade UBNT

Hotspot Captive Portal problemas de redirecionamento com https !

Olá,

- Topologia
- Unifi AC LITE Firmware 4.0.54.10625
- Unifi Controller Versão 5.11.39.0 sobre o Ubuntu 16.04 LTS
- Roteador Mikrotik RB 760IGS Firmware v6.45.5


- Portas do Firewall no Mikrotik aberta para entrada/saída e interna/externa
- VLAN no Mikrotik ID-10 com faixa de IP: 10.0.0.0/24 com DHCP server isolado
- Rede corporativa 192.168.25.0/24 - DHCP próprio 





- Ambos as redes funcionando ok e internet normal.

No Controller tenho duas SSID





CLIENTES - VLAN 10
CORPORATIVO - Rede Normal

Consigo navegar normal nas duas redes pelo WIFI. Pois bem, depois de tudo navegando, habilito a polícia de guest portal no SSID CLIENTES.
Configurei tudo a questão de personalizar a land page, habilitar como hotspot, autenticação open e liberar internet por voucher. Fiz tudo isso
e abriu legal a página de voucher e informei o mesmo na página e começou a navegar, mas algo muito chato acontece e já pesquisei em 
vários locais o problema, quando se entra com uma página com http://exemplo.com, rapidamente ele redireciona para o land page para inserir o voucher e aí depois de inserido navega normal. Mas se quando for logar uma nova conexão no PC e digito https://www.uol.com.br ou https://www.google.com, aí fica pensando até dar time out ou talvez vai de alguma forma, mas demora muito tempo, eu já tomei o cuidado do firewall não bloquear o land page e tudo, portas aberta, mas tem esse problema chato, tudo que começa com https simplesmente ele não rediciona para pedir o voucher, só com http, alguém tem um diagnóstico pra resolver isso?







Comentários

  • R4V3RR4V3R 8420 Pontos
    De acordo com sua configuração, não há nada de errado, já que é exatamente dessa forma que está atualmente configurado pra funcionar, estando o redirecionamento de sites HTTPS está claramente desabilitado.
    No entanto, não basta apenas habilitar esse recurso, você precisa também inserir um certificado digital válido para o domínio onde está hospedado a controladora, e isso, isso sim vai ser BEM mais complicado, embora tenha mais de uma forma de se fazer. ;)
    Aqui tem instruções referente à uma das formas de se inserir um certificado SSL válido na controladora, sem isso você vai acabar recebendo erro durante o redirecionamento e, por questões de segurança, os dispositivos tanto android como ios devem impedí-lo de continuar. 
    https://help.ubnt.com/hc/en-us/articles/212500127-UniFi-SSL-Certificate-Error
  • Cheguei até habilittar, mas aí acontece isso mesmo, não avança pedindo reconhecimento de certificado, vou tentar essa dica aí.

    obrigado.

    Antonio.
  • R4V3RR4V3R 8420 Pontos
    Redirecionamento HTTP exige um certificado válido instalado... Isso é assim pra qualquer equipamento e/ou serviço.
Entre ou Registre-se para fazer um comentário.