Bem-vindo à Comunidade UBNT

Porta Gigabit

Boa noite. Estou com um problema e não estou conseguindo solucionar. Tenho instalado um Edgerouter X (firmware atualizado v1.9.7) e um Toughswitch poe 5 portas (firmware SW.v1.3.5). O problema é o seguinte, no EdgeRouter tenho 4 LINKS, totalizando de 185 mbps, todos os modens sobem com porta gigabit normalmente, mas, a porta que faz a comunicação entre o Edgerouter e o toughswitch não está subindo gigabit, está apenas /100. Troquei todas as portas, reconfigurando tudo, mas não adianta, a porta do EdgeRouter não vira gigabit. Com isso, a velocidade máxima que navega, é de 99 mbps.

Alguém sabe alguma forma de configurar via terminal, ou outra configuração qualquer para "obrigar" a porta a trabalhar gigabit, removendo de autonegociação (que só aparece 100 full/half ou 10 full/half)?
Rotulado:

Comentários

  • pttptt 505 Pontos
    editado agosto 2017

    - Verifique se você não está conectado à porta "gerenciamento" do "ToughSwitch"

  • ptt disse:

    - Verifique se você não está conectado à porta "gerenciamento" do "ToughSwitch"

    não... estou em uma das 5 portas gigabit que ele possui.
  • pttptt 505 Pontos
    editado agosto 2017

    Você testou com outro patchord?

    "Gigabit" deve ser "negociado automaticamente" a maioria dos dispositivos não permitem "Forçar"


  • testei sim..... com cabo cat6, inclusive conectores cat6

  • pttptt 505 Pontos

    O ER-X não permitiria que você configurasse a velocidade da interface para "Gigabit"


    ptt@erx# set interfaces ethernet eth4 speed 1000
    Speed must be auto, 10, or 100

    Value validation failed
    Set failed
    [edit]
    ptt@erx#

  • pttptt 505 Pontos

    No ER-X você pode tentar com "sudo ethtool -s ethX speed 1000 duplex full"

    Sendo "X" a porta que deseja configurar / forçar

  • tentei essa configuração. Caiu o serviço, tive que resetar e reconfigurar
    Não deu muito certo não!!!
  • R4V3RR4V3R 8455 Pontos
    * Não existe "obrigar" a porta a conectar em 1000mbps, se as condições estiverem corretas isso irá ocorrer sempre, por isso elas são configuradas em modo automático por padrão.
    Infelizmente você vai ter que testar com outros cabos, colocando um switch gigabit no meio, etc, até descrobrir o que há de errado, pois com certeza, é um problema físico, ou seja, cabeamento e/ou meio físico.
  • R4V3R disse:

    * Não existe "obrigar" a porta a conectar em 1000mbps, se as condições estiverem corretas isso irá ocorrer sempre, por isso elas são configuradas em modo automático por padrão.

    Infelizmente você vai ter que testar com outros cabos, colocando um switch gigabit no meio, etc, até descrobrir o que há de errado, pois com certeza, é um problema físico, ou seja, cabeamento e/ou meio físico.
    Irei realizar o procedimento, conforme sua especificação. Obrigado!
  • * Não existe "obrigar" a porta a conectar em 1000mbps, se as condições estiverem corretas isso irá ocorrer sempre, por isso elas são configuradas em modo automático por padrão.
    Infelizmente você vai ter que testar com outros cabos, colocando um switch gigabit no meio, etc, até descrobrir o que há de errado, pois com certeza, é um problema físico, ou seja, cabeamento e/ou meio físico.
    Realizei a alteração em conformidade com seu relato, e não deu certo. Troquei todos os cabos (inclusive os cabos que estavam funcionado gigabit) e incluí um switch gigabit da TP-LINK (Modelo TL-SG1024D). O Switch Tp-link com o ToughSwitch comunicaram normalmente em gigabit, mas entre o Tp-link e o EdgeRouter X somente /100, também realizei o teste de cabo, coloquei o cabo que está funcionado em gigabit para realizar a comunicação entre os aparelhos, e nada, já na outra extremidade, o cabo que estava funcionando /100 funcionou em gigabit. Portanto, chego a conclusão que não é meio físico conforme pleiteado, mas sim, algum meio lógico no EdgeRouter X que está inibindo a configuração.

    Tenho aqui, um EdgeRouter POE 5 portas, que estava utilizando anteriormente e funcionava na mesma configuração em Gigabit, mas do nada, ele começou a travar e não subia os links, nem reiniciando. Tinha que proceder o Reset e reconfigurar tudo. Estava acontecendo com uma frequência enorme, a cada 2 horas no máximo tinha que refazer, isso quando subia.... atualizei o firmware, fiz downgrade de firmware para ver se era algum problema de versão de firmware, mas não consegui resolver, por isso, tive que comprar o EdgeRouter X.

    Segue a configuração, para análise, se há alguma coisa nas entrelinhas, que está me prejudicando. Desde já, Obrigado.

    firewall {
        all-ping enable
        broadcast-ping disable
        ipv6-receive-redirects disable
        ipv6-src-route disable
        ip-src-route disable
        log-martians enable
        modify WLB {
            rule 10 {
                action modify
                destination {
                    port 443
                }
                modify {
                    lb-group HTTPS
                }
                protocol tcp
            }
            rule 20 {
                action modify
                modify {
                    lb-group LB-LAN
                }
            }
        }
        name WAN_IN {
            default-action drop
            description "WAN to internal"
            rule 10 {
                action accept
                state {
                    established enable
                    related enable
                }
            }
            rule 20 {
                action drop
                state {
                    invalid enable
                }
            }
        }
        name WAN_LOCAL {
            default-action drop
            description "WAN to router"
            rule 10 {
                action accept
                state {
                    established enable
                    related enable
                }
            }
            rule 20 {
                action drop
                state {
                    invalid enable
                }
            }
        }
        receive-redirects disable
        send-redirects enable
        source-validation disable
        syn-cookies enable
    }
    interfaces {
        ethernet eth0 {
            address 192.168.X.X/24
            description LAN
            duplex auto
            firewall {
                in {
                    modify WLB
                }
            }
            speed auto
        }
        ethernet eth1 {
            address dhcp
            description "VIVO (XXXX-8384) 50mbps"
            duplex auto
            firewall {
                in {
                    name WAN_IN
                }
                local {
                    name WAN_LOCAL
                }
            }
            speed auto
        }
        ethernet eth2 {
            address dhcp
            description "GVT (XXXX-94XX) 50mbps"
            duplex auto
            firewall {
                in {
                    name WAN_IN
                }
                local {
                    name WAN_LOCAL
                }
            }
            ip {
            }
            mtu 1500
            speed auto
        }
        ethernet eth3 {
            address dhcp
            description "VIVO (3032-XXXX) 50mbps"
            duplex auto
            firewall {
                in {
                    name WAN_IN
                }
                local {
                    name WAN_LOCAL
                }
            }
            speed auto
        }
        ethernet eth4 {
            address dhcp
            description "VIVO (35XX-XX11) 35mbps"
            duplex auto
            firewall {
                in {
                    name WAN_IN
                }
                local {
                    name WAN_LOCAL
                }
            }
            mtu 1500
            poe {
                output off
            }
            speed auto
        }
        loopback lo {
        }
    }
    load-balance {
        group HTTPS {
            interface eth1 {
            }
            interface eth2 {
                failover-only
            }
            lb-local enable
            lb-local-metric-change disable
        }
        group LB-LAN {
            interface eth1 {
            }
            interface eth2 {
            }
            interface eth3 {
            }
            interface eth4 {
            }
            lb-local enable
            lb-local-metric-change disable
        }
    }
    protocols {
        static {
        }
    }
    service {
        dhcp-server {
            disabled false
            hostfile-update disable
            shared-network-name Serverdhcp {
                authoritative disable
                subnet 192.168.X.X/24 {
                    default-router 192.168.X.1
                    dns-server 192.168.X.1
                    dns-server 200.175.5.139
                    lease 86400
                    start 192.168.X.X {
                        stop 192.168.X.X
                    }
                }
            }
            use-dnsmasq disable
        }
        dns {
            forwarding {
                cache-size 1000
                listen-on eth0
            }
        }
        gui {
            http-port 80
            https-port 443
            older-ciphers enable
        }
        nat {
            rule 5000 {
                outbound-interface eth1
                type masquerade
            }
            rule 5002 {
                log disable
                outbound-interface eth2
                protocol all
                type masquerade
            }
            rule 5003 {
                log disable
                outbound-interface eth3
                protocol all
                type masquerade
            }
            rule 5005 {
                log disable
                outbound-interface eth4
                type masquerade
            }
        }
        ssh {
            port 22
            protocol-version v2
        }
    }
    system {
        host-name router
        login {
            user will {
                authentication {
                    encrypted-password $6$Qwrs69wrP$BNaQdoiw8lipUOW0d4SFOLpSWwMxyrd5HttLGRkRg0Ifne9e0vBTulCYwWZ9F/1oYIAaQrqwaL1ax.L7aMDiq0
                    plaintext-password ""
                }
                full-name "William Pacheco"
                level admin
            }
        }
        ntp {
            server 0.ubnt.pool.ntp.org {
            }
            server 1.ubnt.pool.ntp.org {
            }
            server 2.ubnt.pool.ntp.org {
            }
            server 3.ubnt.pool.ntp.org {
            }
        }
        package {
            repository squeeze {
                components "main contrib non-free"
                distribution squeeze
                password ""
                url http://http.us.debian.org/debian
                username ""
            }
            repository squeeze-security {
                components main
                distribution squeeze/updates
                password ""
                url http://security.debian.org
                username ""
            }
            repository wheezy {
                components "main contrib non-free"
                distribution wheezy
                password ""
                url http://http.us.debian.org/debian
                username ""
            }
            repository wheezy-security {
                components main
                distribution wheezy/updates
                password ""
                url http://security.debian.org
                username ""
            }
        }
        syslog {
            global {
                facility all {
                    level notice
                }
                facility protocols {
                    level debug
                }
            }
        }
        time-zone America/Sao_Paulo
        traffic-analysis {
            dpi enable
            export enable
        }
    }


    /* Warning: Do not remove the following line. */
    /* === vyatta-config-version: "config-management@1:conntrack@1:cron@1:dhcp-relay@1:dhcp-server@4:firewall@5:ipsec@5:nat@3:qos@1:quagga@2:system@4:ubnt-pptp@1:ubnt-unms@1:ubnt-util@1:vrrp@1:webgui@1:webproxy@1:zone-policy@1" === */
    /* Release version: v1.9.7.5001797.170720.0129 */
       
  • R4V3RR4V3R 8455 Pontos
    Bom, as configurações não irão influenciar essa questão, a não ser que você configure manualmente a velocidade das portas, o que não é recomendado fazer na grande maioria dos casos. Problemas de negociação de velocidade são sempre físicos, e tipicamente estão relacionados ao cabo utilizado, mas podem também ter a ver com o switch ou o próprio roteador. É bastante improvável de ocorrer, e eu nunca vi isso com nenhum edgerouter, mas não quer dizer que seja impossível de ocorrer, logicamente.
    A recomendação é testar cabos diferentes, portas diferentes, ou substituir um dos equipamentos em última instância.
Entre ou Registre-se para fazer um comentário.